Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 25, 2025 - 21:00 UTC
Scheduled
We routinely need to carry out maintenance work on our network. This work is required in order to improve our network infrastructure and ensure continued high levels of resiliency, reliability, security and scalability.
Network maintenance will be carried out on Tuesday 25th March 2025, between 21:00 – 23:59 (GMT)
Impact: Your services should remain completely usable throughout the maintenance window, however the work does carry a low risk, and an interruption to the services listed above could be experienced.
Posted Mar 18, 2025 - 14:54 UTC
This scheduled maintenance affected: SIP Servers, Hosting, Portals (Telecoms and Connectivity Support - https://portal.telappliant.com/, IT Support Portal - https://telappliant.itclientportal.com/, UServe - https://portal.orbtalk.co.uk, Wholesale Portal - https://wapi.breathecall.com/portal/, VoipTalk - https://www.voiptalk.org/), and Connectivity (Leased Line Services).