Electrical works at Skyline Village - Impacting connectivity

Incident Report for Telappliant Status Page

Resolved

All circuits appear to be stable and operational following the circuit breaker replacement. If you experience any further issues, please contact our support team at support@telappliant.com or by calling 0345 004 4040.
Posted Dec 09, 2025 - 17:07 UTC

Monitoring

We have received an update from the engineers confirming that the circuit breaker has been replaced, and we are seeing the connections restored. We are actively monitoring the system to ensure continued stability.
Posted Dec 09, 2025 - 12:00 UTC

Update

Our engineers are on site inspecting the circuit breaker and determining replacement requirements. Further updates will be issued soon.
Posted Dec 09, 2025 - 10:56 UTC

Identified

We have been alerted of a faulty circuit breaker at the Skyline site that is currently impacting the electrical system. The issue is under active investigation, and remediation efforts are underway. Further updates will be provided as the situation progresses.
Posted Dec 09, 2025 - 10:09 UTC
This incident affected: Connectivity (Leased Line Services).