Please re-test your services and let us know if you continue to experience any issues with your calls. If the problem persists, don't hesitate to contact our support team at 0345 004 4040.
Posted Nov 20, 2024 - 13:03 UTC
Monitoring
The issue impacting inbound and outbound calls earlier this morning has now been resolved. Our engineers are currently investigating the root cause, and we will provide further details as soon as they become available. We sincerely apologize for the disruption experienced this morning and appreciate your understanding.
Posted Nov 20, 2024 - 11:39 UTC
Identified
Telappliant is aware of ongoing issues with one of our Primary Inbound/Outbound Call carriers, resulting in the degradation/loss of calls transiting via them. Telappliant Engineers are currently investigating and liasing with our Carrier to restore service. Engineers have located the cause and are in the process of fully restoring service - more updates will follow as soon as they are available.
Posted Nov 20, 2024 - 11:28 UTC
Investigating
Telappliant is aware of ongoing issues with one of our Primary Inbound/Outbound Call carriers, resulting in the degradation/loss of calls transiting via them. Telappliant Engineers are currently investigating and liasing with our Carrier to restore service.