Following the recent disruptions affecting major UK mobile carriers, we’re pleased to confirm that the situation has stabilised over the weekend. Our monitoring indicates a return to normal service levels, and this is being echoed across various social media updates and status pages. We recommend re-testing your services. If you continue to experience any issues with your calls, please contact our support team on 0345 004 4040 (Options 1, 2, then 1) or email us at support@telappliant.com. For more information on the previous issues, please see: https://www.techradar.com/news/live/vodafone-ee-o2-outage-july-2025
Posted Jul 28, 2025 - 12:31 UTC
Monitoring
Following on from the update below, our monitoring indicates that while the issue has not yet been fully resolved, there has been a noticeable improvement in call success rates to EE mobile numbers. We will continue to observe the situation and share any updates we receive. Please find information of the ongoing issues here - https://www.techradar.com/news/live/vodafone-ee-o2-outage-july-2025
Posted Jul 25, 2025 - 16:10 UTC
Update
Several major UK mobile carriers — including BT, Vodafone, O2, Three, and EE — experienced a widespread outage yesterday, disrupting call services nationwide. Although the issue was reportedly resolved by around 9:30 PM on Wednesday, 24th July, we are still seeing ongoing reports on social media indicating that some users may continue to experience issues today, 25th July 2025. Please find information of the ongoing issues here - https://www.techradar.com/news/live/vodafone-ee-o2-outage-july-2025