Connectivity circuits are currently impacted due to an ongoing MSO

Incident Report for Telappliant Status Page

Resolved

We can confirm that all services have been successfully restored and are currently stable. Our team will continue to closely monitor the environment to ensure ongoing stability.
Posted Nov 29, 2025 - 01:55 UTC

Investigating

We were alerted to connectivity issues affecting multiple sites at approximately 00:05 today. Our team is currently investigating the matter and will provide further updates shortly.
Posted Nov 29, 2025 - 01:01 UTC
This incident affected: Connectivity (Leased Line Services).